How do you run this thing?

Oct 8, 2012 at 10:43 AM
Edited Oct 8, 2012 at 10:45 AM

1.  I don't have VS 2010 installed, but I do have VS 2010 Shell.  For some reason it was installed when VS 2012 was installed.  Is the shell sufficient?

2.  Where are the instructions on how to run this thing?

Oct 10, 2012 at 4:01 AM

The Visual Studio Shell will give you some of the basic icons but since packages such as VB, C#, WPF etc. aren't installed with it you won't get all of the icons. I haven't tried this with just the shell but my guess is that's not sufficient and you'll need access to a full copy of VS2010 or for someone else to extract the images for you.

You can look and see if the needed DLLs are installed, the list of files we work against can be found in the Helpers.cs file and the root folders are C:\Program Files (x86)\Microsoft Visual Studio 10.0\ for 2010 and C:\Program Files (x86)\Microsoft Visual Studio 11.0\ for 2012.

If you choose to get the images from another install you'll need to run just the extract command. Then you can copy the Images folder to the same folder as vsip.exe on your machine and then run the inject command.

The Documentation section lists all the commands and their options, alternatively you can see them inside the app by using '?' to show help. To run this you can either open it through the command line or by double clicking it. If you're running on a machine with only one version of Visual Studio installed you'll need to run via the command line and pass in either injectmode or extractmode depending on which version of Visual Studio you're working against.

If both VS2010 and 2012 are installed you can run all the commands one after the other like so

> vsip.exe
> backup -v=2012
> extract
> inject

If you're working against each version individually then you'd do

> vsip.exe extractmode
> extract

> vsip.exe injectmode
> backup -v=2012
> inject

Feb 6, 2013 at 5:28 PM
Edited Feb 6, 2013 at 7:17 PM
Where do you run those commands? In a cmd prompt?

Figured it out, I wasn't running it as administrator on my windows 8 pc. After I ran the vsip.exe as admin it opened the command prompt correctly.