Getting error on launch

Sep 24, 2012 at 7:23 PM

C:\Users\Charlie Hayes\Desktop\VSIP-1.5.1>vsip info
Unhandled Exception: System.NullReferenceException: Object reference not set to an instance of an object.   at IconPatcher.Program.LoadLanguagesFor2010(String[]& allLanguages) in d:\Visual Studio Icon Patcher\Development\src\Icon Patcher\Program.cs:line 63   at IconPatcher.Program.LoadLanguages() in d:\Visual Studio Icon Patcher\Development\src\Icon Patcher\Program.cs:line 46   at IconPatcher.Program.Main(String[] args) in d:\Visual Studio Icon Patcher\Development\src\Icon Patcher\Program.cs:line 31

Coordinator
Sep 26, 2012 at 5:52 AM

Version 1.5.2 was just released which better detects which edition of Visual Studio is installed. Give this a try and see if the error persists.

Sep 27, 2012 at 6:23 PM
Do I need vs2010 and vs2012 installed to get the old icons in the new vs?

-Charlie

On Sep 26, 2012, at 12:52 AM, xt0rted wrote:

From: xt0rted

Version 1.5.2 was just released which better detects which edition of Visual Studio is installed. Give this a try and see if the error persists.


Coordinator
Sep 27, 2012 at 9:38 PM

You will need access to VS 2010, but it doesn't have to be installed on the same machine as VS 2012. This is what extract & inject mode allow you to do which are called on startup via  vsip extractmode  or  vsip injectmode. Once you extract the icons from VS 2010 you can copy the Images folder over to another machine and then just run the inject command.